HDU 1059 Dividing(多重背包二进制优化)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21355    Accepted Submission(s): 6017


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source

【题意】问:给出6种宝石,价值分别是123456,再给出各个数目,问能否正好分成两半

【思路】:多重背包,该题数据目测很大,用二进制优化过后还跑了500+MS

【感悟】:基本套路一般都是将数量拆分

【代码】:
#include<stdio.h>
#include<math.h>
#include<string.h>
#define MAX(a,b) (a>b?a:b)//宏定义比大小
int main()
{
    int f[7], i, j, k, W[23000], dp[50000], sum, a, count = 0;
    while(scanf("%d%d%d%d%d%d",&f[1],&f[2],&f[3],&f[4],&f[5],&f[6]),f[1]+f[2]+f[3]+f[4]+f[5] + f[6])
    {
        k = 1, sum = 0;
        memset(dp,0,sizeof(dp));//必须初始化
        for(i = 1; i <= 6; i++)//将物品按二进制分离, 不懂得下面会给链接,这里就不多解释了。
        {
            sum += f[i] * i;//所有物品的总价值
            for(j = 1; j <= f[i]; j <<= 1)
            {
                W[k++] = j * i;//物品的价值
                f[i] -= j;
            }
            if(f[i] > 0)
            {
                W[k++] = f[i] * i;
            }
        }
        a = sum / 2;//以物品总价值的一半为背包容量
        for(i = 1; i < k; i++)//每一件物品
        {
            for(j = a; j >= W[i]; j--)//dp中保存物品的价值
                dp[j] = MAX(dp[j],dp[j - W[i]] + W[i]);
        }
        printf("Collection #%d:\n",++count);
        if(dp[a] == sum - a)//判断是否与另一半的相等就OK了.
            printf("Can be divided.\n\n");
        else
            printf("Can't be divided.\n\n");
    }
    return 0;
}



【第二种方法】:同样是用二进制优化这方法之前试过,结果WA了,后来加了个剪枝,将sum/2,直接水果,同样500+MS

【代码】:
#include<iostream>
#include<algorithm>
#define maxn 430000
using namespace std;
int dp[maxn], n, k;
int v[20], w[20], V;
int max(int a, int b) {
	return a > b ? a : b;
}
void zero(int cost) {
	for (int i = V; i >= cost; i--)
		dp[i] = max(dp[i], dp[i - cost] + cost);
}
void complet(int cost) {
	for (int i = cost; i <= V; i++)
		dp[i] = max(dp[i], dp[i - cost] + cost);
}
void multi(int cost, int amount) {
	if (cost * amount >= V) {
		complet(cost);
		return;
	}
	int k = 1;
	while (k < amount) {
		zero(k * cost);
		amount -= k;
		k <<= 1;
	}
	zero(amount * cost);
}
int main() {
	int cas = 1;
//    freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
	while (scanf("%d%d%d%d%d%d", &w[0], &w[1], &w[2], &w[3], &w[4], &w[5])
			!= EOF && (w[0] + w[1] + w[2] + w[3] + w[4] + w[5])) {
		int sum = 0;
		for (int i = 0; i < 6; i++)
			v[i] = i + 1;
		for (int i = 0; i < 6; i++) {
			sum += v[i] * w[i];
		}
		if (sum & 1) {
			printf("Collection #%d:\n", cas++);
			printf("Can't be divided.\n\n");
			continue;
		}
		memset(dp, -1, sizeof(dp));
		V = sum / 2;
		dp[0] = 0;
		for (int i = 0; i < 6; i++)
			multi(v[i], w[i]);
		printf("Collection #%d:\n", cas++);
		if (dp[V] == V)
			printf("Can be divided.\n\n");
		else
			printf("Can't be divided.\n\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值