Description
在二叉树的遍历中,我们无法根据已知的前序遍历与后序遍历的结果,来确定一棵树,在如下的三棵树中
它们的前序与后序遍历都是一样的。
在多叉树中也是如此,现在给定“叉”的数目,及前序和后序遍历的结果。
问有多少棵树可以构造出来。
它们的前序与后序遍历都是一样的。
在多叉树中也是如此,现在给定“叉”的数目,及前序和后序遍历的结果。
问有多少棵树可以构造出来。
Input
本题有多组数据。
每个数据,第一个数字N代表树的“叉”数,接着给出这棵树的前序遍历和后序遍历
Output
如题
Sample Input
2 abc cba
2 abc bca
10 abc bca
13 abejkcfghid jkebfghicda
0
Sample Output
4
1
45
207352860
HINT
Source
East Central North America 2002
- 在不作其他规定的情况下,对于一般的m叉树,dfs的方式仅有先根遍历和后根遍历。先根遍历和后根遍历都是递归定义的过程。
- 先根遍历:访问根结点;然后按顺序先根遍历第0、1、2...m-1棵子树。后根遍历:按顺序后根遍历第0、1、2...m-1棵子树;然后访问根结点。
若给定m叉树的先根遍历和后根遍历序列,我们可以重建树的大致形状。举个例子,样例输入中的"13 abejkcfghid jkebfghicda":
最后得:
因此共计C(13, 3)*C(13, 1)*C(13, 4)*C(13, 2)=207352860种可能性。
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
#include <vector>
#define MAXLEN 30
char pre[MAXLEN];
char post[MAXLEN];
vector<int> branch_vec;
//计算n!
int factorial(int n)
{
int result=1;
if (n==0) return 1;
else
{
for (int i=1; i<=n; ++i) result *= i;
return result;
}
}
//计算C(n, m)
int calc_C(int n, int m)
{
unsigned int tmp=1;
for (int i=0; i<m; ++i, --n) tmp*=n;
return (tmp/(factorial(m)));
}
//计算每一个根结点有多少分支(子树)
void branch_count(int pr1, int pr2, int po1, int po2) //参数是:preOrder序列的起止下标、postOrder序列的起止下标
{
int a,b,len, branch=0;
if(pr1==pr2 && po1==po2) return; //递归出口:这个根结点没有任何子树。
else
{
a=pr1+1;
b=po1;
len=0;
while (b<po2)
{
while ( (pre[a] != post[b+len]) && (b+len<po2) ) ++len;
++branch; //每找到一个子树,++branch
branch_count(a, a+len, b, b+len); //对这个子树递归执行branch_count
a=a+len+1;
b=b+len+1;
len=0;
}
branch_vec.push_back(branch); //这个根结点的branch数目存入vector容器
}
}
int main()
{
freopen("D:\\in.txt", "r", stdin);
freopen("D:\\out.txt", "w", stdout);
int m, init_len, ans;
while (1)
{
scanf("%d", &m);
if(m==0) break;
else
{
scanf("%s%s", pre, post);
init_len=strlen(pre);
branch_count(0, init_len-1, 0, init_len-1);
ans=1;
for (int i=0; i<branch_vec.size(); ++i)
{
ans*=(calc_C(m, branch_vec[i]));
}
printf("%d\n", ans);
branch_vec.clear();
}
}
return 0;
}