Max Sum(DP)

Max Sum

Given a sequence a 1 1,a 2 2,a 3 3......a n n, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

解题思路:

定义一个dp[i]表示前i个数的最大连续子序列的和,动态转移方程为

if(dp[i-1] < 0)dp[i] = a[i];

else dp[i] = dp[i-1] + a[i];

再记录一个Now_begin,Now_end。用于更新Max_begin,Max_end;

再对dp[i]求一个最大值。
不难发现当我们处理dp[i]的时候,只需要用到dp[]i-1],所以我们可以只用一个临时变量来储存,将空间进行优化。
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 100000 + 5;

int a,f;
int Max_ans,Max_begin,Max_end;
int Now_begin,Now_end;

int main()
{
    int T,cas = 0;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        cas++;
        scanf("%d",&n);
        for(int i = 1;i <= n; i++)
        {
            int a;
            scanf("%d",&a);
            if(i == 1)
            {
                Max_ans = f = a;
                Now_begin = Now_end  = 1;
            }
            else
            {
                if(f < 0)
                {
                    Now_begin = i;
                    f = a;
                }
                else f += a;
            }
            if(f >= Max_ans)
            {
                Max_ans = f;
                Max_begin = Now_begin;
                Max_end = i;
            }
        }
        printf("Case %d:\n%d %d %d\n",cas,Max_ans,Max_begin,Max_end);
        if(T)printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值