02-线性结构2 Reversing Linked List

 

 

02-线性结构2 Reversing Linked List   (25分)

Given a constant KK and a singly linked list LL, you are supposed to reverse the links of every KK elements on LL. For example, given LL being 1→2→3→4→5→6, if K = 3K=3, then you must output 3→2→1→6→5→4; if K = 4K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive NN (\le 10^5105) which is the total number of nodes, and a positive KK (\le NN) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then NN lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Nextis the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

 

 

 

#include <iostream>
#include <stdio.h>
#define     N   100001
///1310-1436
using namespace std;
struct node
{
    int id;
    int  va;
    int next;
} NODE[N];
void display(int start)
{
    int pt=start;
    while(pt!=-1)
    {
        printf("%05d %d ",pt,NODE[pt].va);
        if (NODE[pt].next!=-1)
        {
            printf("%05d\n",NODE[pt].next);
        }
        else
        {
            printf("-1\n");
        }
        pt=NODE[pt].next;
    }
}
int main()
{
    int start, n,k, i,j,t;
    int pt,pr,nx,ndnum=0,times=0,rePta,rePtb;
    cin>>start>>n>>k;
    for (i=0; i<n; i++)
    {
        cin>>t;
        cin>>NODE[t].va>>NODE[t].next;
    }
    pt=start;
    while(pt!=-1)
    {
        ndnum++;
        pt=NODE[pt].next;
    }
    times=ndnum/k;
    //display(start);
    if (k!=1)
    {
        pr=-1;
        pt=start;

        for (j=1; j<=times*k; j++)
        {
            if (j%k==1)
            {
                rePta=rePtb;
                rePtb=pt;

            }
            else if (j%k==0)
            {
                if (j==k)
                {
                    start=pt;
                }
                else
                {
                    NODE[rePta].next=pt;
                }
            }
            nx=NODE[pt].next;
            NODE[pt].next=pr;
            pr=pt;
            pt=nx;
        }
        NODE[rePtb].next=pt;
    }


    display(start);



    return 0;
}


 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值