贪心-Prime-(百练)1287:Networking

描述
You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

输入
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

输出
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

样例输入
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

样例输出
0
17
16
26

解题思路
①告诉n个图,求每个图内的最小生成树的权值
②最后以输入0结束
③每输入一个图调用Prime算法即可,再输出其最小生成树的权值。

链接: 贪心-最小生成树-Prime

Code:

#include<iostream>
#include<algorithm>
#include<vector>
#include<numeric>
using namespace std;
int N,M;
struct T{
	int to,w;//下一个节点  权值 
};
vector<vector<T>>Edge;//存储边的信息及权值 
vector<int>d;//存储每个点的 
vector<bool>used;//是否被使用过 
int ans=0;//记录权值之和 
void Prime(){
	for(int i=0;i<=N;i++)//把所有节点到已有生成树的距离为无穷大 
		d[i]=0x3f3f3f3f;
	d[1]=0;//开始点为0 
	while(true){
		int x=-1;
		for(int i=1;i<=N;i++)
			if(!used[i]&&(x==-1||d[i]<d[x]))//找出未被访问  且是生成树外的最小节点 加入生成树中  
				x=i;
		if(x==-1)//图里没有小的了  如果有 则是不连通图  再对其它连通片执行Prim()算法 得出来就是此图的最小生成森林 
			break; 
		used[x]=true;//标记为已访问 
		ans+=d[x];//记录权值 
		for(auto &e:Edge[x])//e是一个结构体 e.to是与x相邻接的边  e.w为边上的权值 
			d[e.to]=min(d[e.to],e.w); //更新x所有连接的边   找出自身已更新的值d[e.to]和边权值[e.w]中小的 
	}
}
int main(){
	cin>>N;//顶点数  边数 
	while(N!=0){
		cin>>M;
		Edge.resize(N+1);//节点1~N 
		d.resize(N+1);
		used.resize(N+1);
		int x,y,w;
		for(int i=1;i<=M;i++){//无向图 
			cin>>x>>y>>w;
			Edge[x].push_back({y,w});
			Edge[y].push_back({x,w});
		}
		Prime();
		cout<<ans<<endl;//输出最小生成树的权值之和 
		used.clear();
		d.clear();
		for(int i=0;i<=N;i++)
			Edge[i].clear();
		cin>>N;
		ans=0;
	} 
	
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值