数据结构实验之链表五:单链表的拆分

Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。 
Input
第一行输入整数N;;
第二行依次输入N个整数。 
Output
第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。 
Example Input
10
1 3 22 8 15 999 9 44 6 1001Example Output
4 6
22 8 44 6 
1 3 15 999 9 1001Hint
不得使用数组! 


#include<stdio.h>
#include<stdlib.h>
typedef struct node{
	int data;
	struct node *next;
}node;
int main(){
	node *head,*tail,*q,*tail1,*head1,*head2,*tail2,*p;
	head=(node *)malloc(sizeof(node));
	head->next=NULL;
	tail=head;
	int n;
	scanf("%d",&n);
	int i;
	for(i=1;i<=n;i++){
		q=(node *)malloc(sizeof(node));
		q->next=NULL;
		scanf("%d",&q->data);
		tail->next=q;
		tail=q;
	}
	head1=(node *)malloc(sizeof(node));
	head1->next=NULL;
	tail1=head1;
	head2=(node *)malloc(sizeof(node));
	head2->next=NULL;
	tail2=head2;
	p=head->next;
	q=p->next;
	while(p!=NULL){
		if(p->data%2==0){
			p->next=NULL;
			tail1->next=p;
			tail1=p;
		}else{
			p->next=NULL;
			tail2->next=p;
			tail2=p;
		}
		p=q;
		if(q!=NULL)
		q=q->next;
	}
	int cnt1=0;
	p=head1->next;
	while(p!=NULL){
		cnt1++;
		p=p->next;
	}
	p=head2->next;
	int cnt2=0;
	while(p!=NULL){
		cnt2++;
		p=p->next;
	}
	printf("%d %d\n",cnt1,cnt2);
	p=head1->next;
	while(p!=NULL){
		if(p->next!=NULL){
			printf("%d ",p->data);
		}else{
			printf("%d\n",p->data);
		}
		p=p->next;
	}
	p=head2->next;
	while(p!=NULL){
		if(p->next!=NULL)
		printf("%d ",p->data);
		else
		printf("%d\n",p->data);
		p=p->next;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值