fabric二进制安装文件binariesInstall下载 https://nexus.hyperledger.org不再维护的解决

fabric 专栏收录该内容
2 篇文章 0 订阅

前言

在https://github.com/hyperledger/fabric/blob/v1.4.3/scripts/bootstrap.sh的配置文件中,下载二进制文件的网址不再维护。
报错nexus.hyperledger.org 未发送任何数据。

binariesInstall() {vb
  echo "===> Downloading version ${FABRIC_TAG} platform specific fabric binaries"
  # https://nexus.hyperledger.org不再维护
  binaryDownload ${BINARY_FILE} https://nexus.hyperledger.org/content/repositories/releases/org/hyperledger/fabric/hyperledger-fabric/${ARCH}-${VERSION}/${BINARY_FILE}
  if [ $? -eq 22 ]; then
     echo
     echo "------> ${FABRIC_TAG} platform specific fabric binary is not available to download <----"
     echo
   fi

  echo "===> Downloading version ${CA_TAG} platform specific fabric-ca-client binary"
  binaryDownload ${CA_BINARY_FILE} https://nexus.hyperledger.org/content/repositories/releases/org/hyperledger/fabric-ca/hyperledger-fabric-ca/${ARCH}-${CA_VERSION}/${CA_BINARY_FILE}
  if [ $? -eq 22 ]; then
     echo
     echo "------> ${CA_TAG} fabric-ca-client binary is not available to download  (Available from 1.1.0-rc1) <----"
     echo
   fi
}

解决办法

如果想下载二进制文件,可以访问以下网址(以1.4.3为例),在最下方的下载连接中找到和自己系统相匹配的。

https://github.com/hyperledger/fabric/releases/tag/v1.4.3

如果是ubuntu系统,可以直接使用

wget https://github.com/hyperledger/fabric/releases/download/v1.4.3/hyperledger-fabric-linux-amd64-1.4.3.tar.gz

解压后的文件如下图所示
在这里插入图片描述

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 护眼 设计师:闪电赇 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值