uva340 - Master-Mind Hints

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other,Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the lengthN that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guesstex2html_wrap_inline37 , and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j), tex2html_wrap_inline41 andtex2html_wrap_inline43 , such thattex2html_wrap_inline45 . Match (i,j) is calledstrong when i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are calledindependent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches inM. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifyingN (the length of the code). Following these will be the secret code, represented asN integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented asN integers, each in the range 1 to 9. Following the last guess in each game will beN zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value forN. The last game in the input will be followed by a single zero (when a value forN would normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for theexact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

给定一个密码串,输入待匹配串,如果相同位置字符相同得到一个A,不同位置的字符相同得到一个B,字符只能匹配一次并且A的优先级大于B就是先算A的然后再B。

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)

 

#include <stdio.h>
void main()
{int i,j,f,n,A,B,a[1010],b[1010],c[1010],sum=0,num;
 while (scanf("%d",&n),n)
 {++sum;
  printf("Game %d:\n",sum);
  for (i=1;i<=n;i++)
  scanf("%d",&a[i]);
  f=1;
  while (f)
  {num=0;
   for (i=1;i<=n;i++)
   {scanf("%d",&b[i]); c[i]=a[i]; if (b[i]==0) ++num; }
    if (num==n) break;
    A=0;B=0;
 for (i=1;i<=n;i++)
 if (c[i]==b[i]) {++A;c[i]=-1;b[i]=-1;}
 for (i=1;i<=n;i++)
    {
     if (c[i]!=-1)
  {
  for (j=1;j<=n;j++)
   if ((c[i]==b[j])) {++B;c[i]=-1;b[j]=-1;break;}
  }
 }
 printf("    (%d,%d)\n",A,B); 
  }
 }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值