从高版本JDK换成低版本JDK报错Unsupported major.minor version 52.0

java.lang.UnsupportedClassVersionError: PR/Sort: Unsupported major.minor version 52.0这个错误是由于高版本的javaproject使用了低版本的来运行。

我出现这个情况是我把Properties中java buildpath-->Libraries中的JVM8换成JVM6

之后运行就报错了

解决方法:
在Properties-->JAVACompiler-中的Compiler compliancelevel从1.8改成1.6,之后就可以运行了。
阅读更多
文章标签: jdk 版本
个人分类: Java
上一篇关于 AnnotationConfigBeanDefinitionParser are only available on JDK 1.5 and higher
下一篇Java基础之理解Annotation
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭