sums



Description

Sometimes Ziwen need to operate even larger numbers. A limit of 1000 digits is so small… You have to find the sum of two numbers with maximal size of 1 000 000 digits.

Input

The first line contains a single integer N that is the length of the given integers(1 ≤ N ≤ 1 000 000). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 0, and the length of their sum does not exceed N. The integers may contain leading zeroes.

Output

Output exactly N digits in a single line representing the sum of these two integers.

Sample Input

4
0 4
4 2
6 8
3 7

Sample Output

4750
代码
#include<iostream>
using namespace std;
main()
{
 int n;
 while(scanf("%d",&n)!=EOF){
  int a[n][2];
  for(int i=0;i<n;i++){
   scanf("%d%d",&a[i][0],&a[i][1]);
  }
  int c[n+1];
  for(int i=0;i<n+1;i++){
   c[i]=0;
  }
  static int k=0;
    for(int i=n-1;i>=0;i--){   
     c[i+1]=(a[i][0]+a[i][1]+k)%10;
     k=(a[i][0]+a[i][1]+k)/10;
    }
    if(c[0]!=0) printf("%d",c[0]);
    for(int i=1;i<n+1;i++){
     printf("%d",c[i]);
    }  
 }
} 
算法还是较简单的,不过在开始测试,发现输出的总是00000X,后面才发现少了using namespace std; 但程序可以运行,不过无法的出正确的结果,原因待究。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值