Check the difficulty of problems (概率DP)poj2151

Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7104 Accepted: 3078

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

为啥分类到哈希表和二分等高效查找法???坑???

#include <iostream>
#include <cstring>
#include <cstdio>
#include <iomanip>
using namespace std;

const int maxn=1010;
double dp[maxn][33] [33];
double p[maxn][33];
double p1,p2;
int m,t,n;

int main()
{
    int i,j,k;
    while(cin>>m>>t>>n)
    {
        if(m==0 && t==0 && n==0)
        {
            return 0;
        }

        for(i=1; i<=t; i++)
        {
            for(j=1; j<=m; j++)
            {
                cin>>p[i][j];
            }
        }
        ///判断dp边界
        for(i=1; i<=t; i++)
        {
            dp[i][0][0]=1.0; ///第i队 前0题 a了0道 概率必然是1
            for(j=1; j<=m; j++)
            {
                dp[i][0][j]=0.0; ///第i队 前0题 a了j(j>=1)道 概率必然是0
                dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]); ///继续求前j道题全错的情况
            }
        }
        ///求dp[i][j][k]的循环过程 第i队 前j题 a了k道
        for(i=1; i<=t; i++)
        {
            for(j=1; j<=m; j++)
            {
                for(k=1; k<=j; k++)
                {
                    dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
                }
            }
        }
        ///p2-p1 就是队伍a至多n道的概率 ??exm ??
        p1=1.0; ///所有队伍a 1~n-1 道的概率
        p2=1.0; ///所有队至少a一道的概率
        for(i=1; i<=t; i++)
        {
            p2=p2*(1-dp[i][m][0]); ///至少a一道
        }

        for(i=1; i<=t; i++)
        {
            double sum=0.0;
            for(j=1; j<n; j++)
            {
                sum+=dp[i][m][j];
            }
            p1=p1*sum;
        }
        printf("%.3f\n",p2-p1);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值