Balance poj1837 (DP & 01背包)


Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14005 Accepted: 8804

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2


不写题解和咸鱼有啥区别

砝码个数勾码个数2~20

砝码重量1~25

勾码坐标-15~15

问 : 到达平衡状态的方法有几种

第一 什么也不放是一种平衡状态

一个砝码放上就有一个平衡度 最大的平衡度为+-15*25*20 = -7500/7500(所有的砝码放一边)

用数组存就要注意避免负数 设8000为平衡点 (只要大于7500就行但太大浪费)

二维数组保存 dp[i-1][j] 表示第i砝码放上 平衡度为j

那么dp[i][ x ] += dp[i-1][j] (因为达到后一个状态x是由之前的状态的基础上操作来的 所以放砝码的方法就是之前的状态,从0累加)

!!!后一个状态的平衡度 x=j+坐标*质量 (放入一个砝码就把所有位置遍历)

状态转移方程 dp[i][ j+坐标*质量 ] += dp[i-1][j]


#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

#define For(i,a,b) for(i=a;i<=b;i++)
#define Out(x) cout<<x<<endl

#define ll long long
const ll inf = 1e10;

int dp[33][16000];

int main()
{
     int i,j,k; 
     int n,m; ///n个勾码 m个砝码
     int wt[33],pos[33]; ///砝码质量 勾码位置

       while(cin>>n>>m)
	{
		For(i,1,n) cin>>pos[i];
		For(i,1,m) cin>>wt[i];
		
		memset(dp,0,sizeof(dp));
		dp[0][8000] = 1; ///设8000为平衡点(这点理论上大于7500随意) 第0个砝码放入则只有1种情况平衡- 
		                 ///-就是不放砝码 

		For(i,1,m) /// 一共m个砝码挨个放
		{
			For(j,0,16000) /// 平衡度0~16000 遍历这些情况
			{
				if(dp[i-1][j]) /// 避免第二维下标出现负数-
				{			   /// -只要没计算过就不进行下面循环
					For(k,1,n) /// 每放一个砝码 都遍历放的位置
					{
						dp[i][ j+pos[k]*wt[i] ] += dp[i-1][j]; ///状态方程 
					}
				}
			}
		}
		Out(dp[m][8000]);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值