欧拉函数的简单应用

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7
12
0
Sample Output
6
4
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;  
int a[1000010];   
  int main()  
{  
	int t;
    int num=0,sum=0,max=0;  
    cin >> t;  
     
        while(t--)  
        {  
        	int n,j=0;  
            cin >> n;  
            for(int i=0;i<n;i++)  
            {  
                cin  >>  a[i] ;  
                if(max<a[i]) 
					max=a[i];  
            }   
            for(j;j<n;j++)  
            {  
                if(a[j]!=max) 
					sum+=a[j];  
                if(sum>=max-1)
				 	break;  
            }  
            if(j==n) 
            	cout << "No" <<endl;
            else 
            	cout << "Yes" <<endl;  
        }  
    
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值