HDU1536-nim博弈入门

一个局面的SG值等于不能到达的局面的最小值,最简单的nim博弈由于可以随便拿,所以比它小的局面都能到达,sg值就为自己本身,求胜负就将所有堆的数字异或就行。

而这题只能拿特定数字,所以局面sg值要打表求出来,再异或求胜负。

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3077    Accepted Submission(s): 1361

Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
  The players take turns chosing a heap and removing a positive number of beads from it.
  The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:
  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
  If the xor-sum is 0, too bad, you will lose.
  Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
  The player that takes the last bead wins.
  After the winning player's last move the xor-sum will be 0.
  The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
Sample Input
  
  
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0

Sample Output
  
  
LWW WWL
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int sg[10009];
int s[109];
int S,t;
void dabiao()
{
    memset(sg, 0, sizeof(sg));
    bool vis[10009];
    for(int i=0; i<10009; i++)
    {
        memset(vis,0,sizeof(vis));
        int h = 0;
        while(i >= s[h] && h < S)
            vis[sg[i - s[h++]]] = true;
        for(int j = 0; j <= i; j++)
        {
            if(!vis[j])
            {
                sg[i] = j;
                break;
            }
        }
    }
    return ;
}
int main()
{
    while(~scanf("%d",&S)&&S)
    {
        for(int i=0; i<S; i++)
            scanf("%d",&s[i]);
        sort(s,s+S);
        dabiao();
        int T;
        scanf("%d",&T);
        while(T--)
        {
            int n;
            scanf("%d",&n);
            int ans=0;
            for(int i=0; i<n; i++)
            {
                scanf("%d",&t);
                ans^=sg[t];
            }
            if(ans)
                putchar('W');
            else
                putchar('L');
        }
        putchar('\n');
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值