洛谷 P1852 奇怪的字符串

题目描述

输入两个01串,输出它们的最长公共子序列的长度

输入输出格式

输入格式:

 

一行,两个01串

 

输出格式:

 

最长公共子序列的长度

 

输入输出样例

输入样例#1: 复制
01010101010 00000011111
输出样例#1: 复制
6

说明

01串长度≤10000

思路:lcs

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
string s1,s2;
int f[5010][5010];
int main(){
    cin>>s1>>s2;
    int len1=s1.length();
    int len2=s2.length();
    s1=' '+s1;s2=' '+s2;
    for(int i=1;i<=len1;i++)
        for(int j=1;j<=len2;j++)
            if(s1[i]==s2[j])    f[i][j]=f[i-1][j-1]+1;
              else    f[i][j]=max(f[i-1][j],f[i][j-1]);
    cout<<f[len1][len2];
}

 

转载于:https://www.cnblogs.com/cangT-Tlan/p/7899933.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值