CF894A QAQ

题意翻译

题目大意: 给定一个字符串,字符串长度<=100,现在要求出字符串中'QAQ'的个数,注意,'QAQ'可以不连续,只要有顺序就可以了,例如QABQ也有一个QAQ

Translated by @Hjl1777

题目描述

"QAQ" is a word to denote an expression of crying. Imagine "Q" as eyes with tears and "A" as a mouth.

Now Diamond has given Bort a string consisting of only uppercase English letters of length nn . There is a great number of "QAQ" in the string (Diamond is so cute!).

illustration by 猫屋 https://twitter.com/nekoyaliuBort wants to know how many subsequences "QAQ" are in the string Diamond has given. Note that the letters "QAQ" don't have to be consecutive, but the order of letters should be exact.

输入输出格式

输入格式:

 

The only line contains a string of length nn ( 1<=n<=1001<=n<=100 ). It's guaranteed that the string only contains uppercase English letters.

 

输出格式:

 

Print a single integer — the number of subsequences "QAQ" in the string.

 

输入输出样例

输入样例#1: 复制
QAQAQYSYIOIWIN
输出样例#1: 复制
4
输入样例#2: 复制
QAQQQZZYNOIWIN
输出样例#2: 复制
3

说明

In the first example there are 44 subsequences "QAQ": "QAQAQYSYIOIWIN", "QAQAQYSYIOIWIN", "QAQAQYSYIOIWIN", "QAQAQYSYIOIWIN".

 

思路:组合数学搞一下就可以了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
string s;
int ans,t,q[100];
int main(){
    cin>>s;int len=s.size();
    for(int i=0;i<s.size();++i)    q[i]=s[i]=='Q'?++t:t;
    for(int i=0;i<s.size();++i)    if(s[i]=='A')    ans+=q[i]*(t-q[i]);
    cout<<ans;
}

 

转载于:https://www.cnblogs.com/cangT-Tlan/p/8441357.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值