洛谷 P2879 [USACO07JAN]区间统计Tallest Cow

题目描述

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

给出牛的可能最高身高,然后输入m组数据 a b,代表a,b可以相望,最后求所有牛的可能最高身高输出

输入输出格式

输入格式:

 

Line 1: Four space-separated integers: N, I, H and R

Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

 

输出格式:

 

Lines 1..N: Line i contains the maximum possible height of cow i.

 

输入输出样例

输入样例#1: 复制
9 3 5 5
1 3
5 3
4 3
3 7
9 8
输出样例#1: 复制
5
4
5
3
4
4
5
5
5
思路:贪心。首先全部赋值为最大值,然后进行贪心。
去重后,把区间l,r之间的值均减去一。
或者先判断区间l,r之间的最大值,如果比两个端点都就不进行修改,防止修改。
不去重
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 10010
using namespace std;
int n,m,pos,maxh;
int h[MAXN];
int main(){
    scanf("%d%d%d%d",&n,&pos,&maxh,&m);
    for(int i=1;i<=n;i++)    h[i]=maxh;
    for(int i=1;i<=m;i++){
        int l,r;
        scanf("%d%d",&l,&r);
        if(l>r)    swap(l,r);
        if(abs(l-r)!=1){
            int maxn=-1;
            for(int j=l+1;j<r;j++)
                maxn=max(maxn,h[j]);
            if(maxn>=min(h[l],h[r]))
                for(int j=l+1;j<r;j++)
                    h[j]-=1;
        }
    }
    for(int i=1;i<=n;i++)
        cout<<h[i]<<endl;
}
去重
#include<set> #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #define MAXN 10010 using namespace std; set<int>se[MAXN]; int n,m,pos,maxh; int h[MAXN]; int main(){ scanf("%d%d%d%d",&n,&pos,&maxh,&m); for(int i=1;i<=n;i++) h[i]=maxh; for(int i=1;i<=m;i++){ int l,r; scanf("%d%d",&l,&r); if(l>r) swap(l,r); if(se[l].find(r)!=se[l].end()) continue; se[l].insert(r); if(abs(l-r)!=1) for(int j=l+1;j<r;j++) h[j]-=1; } for(int i=1;i<=n;i++) cout<<h[i]<<endl; }

 

 

转载于:https://www.cnblogs.com/cangT-Tlan/p/7791563.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 有一个长度为 $n$ 的书架,每本书有一个高度 $h_i$。现在你可以进行以下两种操作: - 将一本书放在书架的最左边或最右边,花费为 $c_1$。 - 将一本高度为 $h_i$ 的书放在一本高度为 $h_j$ 的书的上面,花费为 $c_2$。 现在你需要将书架上的书按照高度从小到大排列,求最小花费。 输入格式 第一行包含三个整数 $n,c_1,c_2$。 第二行包含 $n$ 个整数 $h_i$。 输出格式 输出一个整数,表示最小花费。 数据范围 $1\leq n\leq 200,1\leq c_1,c_2\leq 10^9,1\leq h_i\leq 10^9$ 输入样例 5 1 2 3 1 4 2 5 输出样例 6 算法1 (动态规划) $O(n^2)$ 首先考虑一个朴素的 dp,设 $f_{i,j}$ 表示前 $i$ 本书已经排好序,第 $i+1$ 本书放在第 $j$ 个位置的最小花费。 状态转移方程为: $$ f_{i,j}=\min\{f_{i-1,k}+c_1\}+\begin{cases}&\text{if }h_{i+1}>h_j\\c_2&\text{otherwise}\end{cases} $$ 其中 $k$ 取遍 $1\sim i$,表示将第 $i+1$ 本书放在第 $k$ 个位置。 时间复杂度 $O(n^3)$ C++ 代码 算法2 (单调队列优化) $O(n^2)$ 考虑优化上述 dp,发现状态转移方程中的 $\min$ 操作可以用单调队列优化,具体来说,我们维护一个单调递增的队列 $q$,其中 $q_i$ 表示第 $i$ 个位置的最小花费,那么对于状态 $f_{i,j}$,我们只需要找到 $q$ 中第一个大于等于 $f_{i-1,k}+c_1$ 的位置 $p$,然后 $f_{i,j}=q_p+\begin{cases}&\text{if }h_{i+1}>h_j\\c_2&\text{otherwise}\end{cases}$。 时间复杂度 $O(n^2)$ C++ 代码

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值