HDU 1242 Rescue (BFS)

5 篇文章 0 订阅

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N*M(N,M\leq 200 ) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

代码

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
#define MAXN 210
struct node{
	int x,y,step;
	friend bool operator< (node a,node b){
		return a.step>b.step;
	}
};
char mat[MAXN][MAXN];
int dir[4][2]={-1,0,0,1,1,0,0,-1};
bool vis[MAXN][MAXN];
int n,m;
void BFS(int x1,int y1,int x2,int y2){
	memset(vis,0,sizeof(vis));
	priority_queue<node> q;
	node t1,t2;
	int ans=-1;
	t1.x=x1,t1.y=y1,t1.step=0;
	q.push(t1);
	vis[x1][y1]=1;
	while(!q.empty()){
		t2=q.top();
		q.pop();
		if(t2.x==x2&&t2.y==y2){
			ans=t2.step;
			break;
		}
		int i;
		for(i=0;i<4;i++){
			t1.x=t2.x+dir[i][0];
			t1.y=t2.y+dir[i][1];
			t1.step=t2.step;
			if(t1.x<0||t1.x>=n||t1.y<0||t1.y>=m||mat[t1.x][t1.y]=='#'||vis[t1.x][t1.y]) continue;
			if(mat[t1.x][t1.y]=='.'||mat[t1.x][t1.y]=='a') t1.step++;
			else t1.step+=2;
			q.push(t1);
			vis[t1.x][t1.y]=1;
		}
	}
	if(ans==-1) cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
	else cout<<ans<<endl;
}
int main(){
	while(cin>>n>>m){
		int i,j;
		int stx,sty,edx,edy;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++){
				cin>>mat[i][j];
				if(mat[i][j]=='r') stx=i,sty=j;
				if(mat[i][j]=='a') edx=i,edy=j;
			}
		BFS(stx,sty,edx,edy);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值