POJ 2376 Cleaning Shifts (贪心)

Description

Farmer John is assigning some of his N(1\leq N \leq 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1\leq T \leq 1,000,000), the first being shift 1 and the last being shift T.
Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.
Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T
* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
INPUT DETAILS:
There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.
OUTPUT DETAILS:
By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

代码

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
#define MAXN 26000
struct interval{
	int l,r;
}time[MAXN];
bool cmp(interval a,interval b){
	if(a.l==b.l) return a.r>b.r;
	else return a.l<b.l;
}
int main(){
	int N,T;
	cin>>N>>T;
	int i;
	for(i=0;i<N;i++){
		cin>>time[i].l>>time[i].r;
		time[i].r++;
	} 
	sort(time,time+N,cmp);
	int maxr,t;
	int ans=0;
	if(time[0].l>1){
		cout<<-1<<endl;
		return 0;
	}
	else{
		maxr=t=time[0].r;
		ans++;
	} 
	if(t==T+1){
		cout<<ans<<endl;
		return 0;
	}
	for(i=1;i<N;i++){
		if(time[i].l>t){
			ans=-1;
			break;
		}
		else if(time[i].l<=maxr){
			t=max(t,time[i].r);
		}
		else{
			ans++;
			maxr=t;
			t=max(t,time[i].r);
		}
		if(t==T+1){
			ans++;
			break;
		}
	}
	if(t!=T+1) cout<<-1<<endl;
	else cout<<ans<<endl;
	return 0;
}

解题思路

读完题第一印象是区间完全覆盖问题,其实这道题本身确实是区间覆盖问题,只不过这道题有它的现实情况。一般的区间完全覆盖问题对于一段区间[1,10][1,5]+[5,10]就可以完全覆盖,而这道题的区间指的是时间段,对于同样的区间[1,10][1,5]+[6,10]就可以完全覆盖,有点像点覆盖问题,但我们任然可以把它看做区间覆盖问题对待,只需要处理一下数据,即将每段区间的右端点+1即可

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值