Harmonic Number LightOJ - 1234 调和级数

问题:

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

                                   

                                                            

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

题意:求和;

公式:f(n)=ln(n)+C+1/(2*n), 公式中C≈0.57721566490153286060651209;但是使用的时候n不能过小, 10000以上的数就可以用这个公式,剩下的就是打表,10000以内的数打表应该非常容易。

思路一:用公式做,代码下;

代码一:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
const double  C = 0.57721566490153286060651209;
double a[100000];
void Init()//打表
{
    a[1]=1;
    for(int i=2; i<=100000; i++)
        a[i]=a[i-1]+double(1.0/i);
}
int main()
{
    int t;
    Init();
    scanf("%d",&t);
    int ca=0;
    while(t--)
    {
        int n;
        scanf("%d", &n);
        if(n<=100000)//小于100000打表输出
            printf("Case %d: %.10lf\n",++ca,a[n]);
        else//大于100000的用公式直接写
            printf("Case %d: %.10lf\n",++ca,log(n)+C+double(1.0/(2*n)));
    }
    return 0;
}

 

思路二:暴力坐,分段打表。

代码二:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
double s[2500002];
void dabiao()
{
    double ss=1.0;
    for(int i=2; i<=100000001; i++)
    {
        ss+=1.0/i;
        if(i%40==0)//进行分段,如果不分段会超内存
            s[i/40]=ss;
    }
}
int main()
{
    dabiao();
    int kk=1,t;
    scanf("%d",&t);
    while(t--)
    {
        int a;
        scanf("%d",&a);
        int k=a/40;
        double sum=s[k];
        for(int i=k*40+1; i<=a; i++)
            sum+=1.0/i;
        printf("Case %d: %.10f\n",kk++,sum);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值