HDU1053 Entropy题解(哈夫曼编码+优先队列)

Entropy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8528 Accepted Submission(s): 3633

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1053

Problem Description
An entropy encoder is a data encoding method that achieves lossless data compression by encoding a message with “wasted” or “extra” information removed. In other words, entropy encoding removes information that was not necessary in the first place to accurately encode the message. A high degree of entropy implies a message with a great deal of wasted information; english text encoded in ASCII is an example of a message type that has very high entropy. Already compressed messages, such as JPEG graphics or ZIP archives, have very little entropy and do not benefit from further attempts at entropy encoding.

English text encoded in ASCII has a high degree of entropy because all characters are encoded using the same number of bits, eight. It is a known fact that the letters E, L, N, R, S and T occur at a considerably higher frequency than do most other letters in english text. If a way could be found to encode just these letters with four bits, then the new encoding would be smaller, would contain all the original information, and would have less entropy. ASCII uses a fixed number of bits for a reason, however: it’s easy, since one is always dealing with a fixed number of bits to represent each possible glyph or character. How would an encoding scheme that used four bits for the above letters be able to distinguish between the four-bit codes and eight-bit codes? This seemingly difficult problem is solved using what is known as a “prefix-free variable-length” encoding.

In such an encoding, any number of bits can be used to represent any glyph, and glyphs not present in the message are simply not encoded. However, in order to be able to recover the information, no bit pattern that encodes a glyph is allowed to be the prefix of any other encoding bit pattern. This allows the encoded bitstream to be read bit by bit, and whenever a set of bits is encountered that represents a glyph, that glyph can be decoded. If the prefix-free constraint was not enforced, then such a decoding would be impossible.

Consider the text “AAAAABCD”. Using ASCII, encoding this would require 64 bits. If, instead, we encode “A” with the bit pattern “00”, “B” with “01”, “C” with “10”, and “D” with “11” then we can encode this text in only 16 bits; the resulting bit pattern would be “0000000000011011”. This is still a fixed-length encoding, however; we’re using two bits per glyph instead of eight. Since the glyph “A” occurs with greater frequency, could we do better by encoding it with fewer bits? In fact we can, but in order to maintain a prefix-free encoding, some of the other bit patterns will become longer than two bits. An optimal encoding is to encode “A” with “0”, “B” with “10”, “C” with “110”, and “D” with “111”. (This is clearly not the only optimal encoding, as it is obvious that the encodings for B, C and D could be interchanged freely for any given encoding without increasing the size of the final encoded message.) Using this encoding, the message encodes in only 13 bits to “0000010110111”, a compression ratio of 4.9 to 1 (that is, each bit in the final encoded message represents as much information as did 4.9 bits in the original encoding). Read through this bit pattern from left to right and you’ll see that the prefix-free encoding makes it simple to decode this into the original text even though the codes have varying bit lengths.

As a second example, consider the text “THE CAT IN THE HAT”. In this text, the letter “T” and the space character both occur with the highest frequency, so they will clearly have the shortest encoding bit patterns in an optimal encoding. The letters “C”, “I’ and “N” only occur once, however, so they will have the longest codes.

There are many possible sets of prefix-free variable-length bit patterns that would yield the optimal encoding, that is, that would allow the text to be encoded in the fewest number of bits. One such optimal encoding is to encode spaces with “00”, “A” with “100”, “C” with “1110”, “E” with “1111”, “H” with “110”, “I” with “1010”, “N” with “1011” and “T” with “01”. The optimal encoding therefore requires only 51 bits compared to the 144 that would be necessary to encode the message with 8-bit ASCII encoding, a compression ratio of 2.8 to 1.

Input
The input file will contain a list of text strings, one per line. The text strings will consist only of uppercase alphanumeric characters and underscores (which are used in place of spaces). The end of the input will be signalled by a line containing only the word “END” as the text string. This line should not be processed.

Output
For each text string in the input, output the length in bits of the 8-bit ASCII encoding, the length in bits of an optimal prefix-free variable-length encoding, and the compression ratio accurate to one decimal point.

Sample Input
AAAAABCD
THE_CAT_IN_THE_HAT
END

Sample Output
64 13 4.9
144 51 2.8

题意分析

题目很长,但其实就是给给你一字符串,分别求固定长度编码得到的长度,和无前缀可变长度编码得到的长度,然后求它们的比值。
固定长度编码长度就等于8*字符串长度,而后者则是用哈夫曼编码得到的编码长度。
所以题目的重点就是要求出用哈夫曼编码的长度,也就是∑(每个字符的编码长度 * 该字符的个数)。
现在题意就变得很明显了,直接对目标字符串进行哈夫曼编码操作就好了,但经过观察我们发现用priority_queue(优先队列)可以很好的解决这个问题。

具体实现
1.用priority_queue把字符出现频率从小到大排序,
2.然后每次取出最小的两个(如果有的话),将它们的和记下 并插入到队列中,
3.重复 2步骤,直到队列中只有一个元素,
4.那么,该值就是我们要的答案。

原理
原理很简单,因为步骤 2的执行次数就等于它位于‘等价哈夫曼树’的层数,也就相当于重复加了(层数-1)次,而层数就是该字符的编码长度,所以也就是(编码长度*该字符个数)。

下面是详细代码样例

#include<bits/stdc++.h>
using namespace std;
char ch[30];
const int maxn=100000;
int main()
{
	char s1[maxn];
	while(~scanf("%s",s1)&&strcmp(s1,"END")!=0)
	{
		int len=strlen(s1);
		memset(ch,0,sizeof(ch));
		for(int i=0;i<len;i++)
		{
			if(s1[i]=='_')
				ch[26]++;
			else
				ch[s1[i]-'A']++;
		}
		priority_queue<int,vector<int>,greater<int> > Q;
		for(int i=0;i<27;i++)
		{
			if(ch[i]>0)
				Q.push(ch[i]);
		}
		int sum=0;
        if(Q.size()==1)
            sum+=Q.top();
        while(Q.size()>=2)
        {
            int p1=Q.top();Q.pop();
            int p2=Q.top();Q.pop();
            sum+=p1+p2;
            Q.push(p1+p2);
        }
        printf("%d %d %.1f\n",len*8,sum,(len*8.0)/sum);
	}
	return 0;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值