杭电1171(01背包+完全背包)

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35650    Accepted Submission(s): 12366


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

题目大意是有一批价值不同设备,尽量按照总价值均分给计算机学院和软件学院(其中计算机学院分得设备的价值不得低于软件学院)。

将总价值sum分为一半mid,然后求得包容量为mid的的背包即可,这样计算机学院和软件学院的设备价值分别为sum-dp[m]和dp[m]。

在处理背包时,某设备的价值*数量若大于mid,即可按照完全背包做;否则,按照01背包做,要注意的是,按01背包做时要注意该设备的数量,需增加一个循环

for(x=1;x<=m[i];x++)


AC代码:

#include <stdio.h>
#include <string.h>
#define max(a,b) a>b?a:b
int main()
{
    int n,i,j,v[100005],m[100005],dp[150005],sum,mid,x;
    while(scanf("%d",&n)!=EOF&&n>=0)
    {
        for(i=0;i<n;i++)
            scanf("%d %d",&v[i],&m[i]);
        sum=0;
        for(i=0;i<n;i++)
            sum+=v[i]*m[i];
        mid=sum/2;
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            if(v[i]*m[i]>=mid)
            {
                for(j=v[i];j<=mid;j++)
                    dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
            }
            else
            {
                for(x=1;x<=m[i];x++)
                    for(j=mid;j>=v[i];j--)
                        dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
            }
        }
        printf("%d %d\n",sum-dp[mid],dp[mid]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值