并查集

并查集:就是有多个帮派,一个帮派有一个大哥;          //这是听了某位老哥的一个说法

并:假如有两个帮派的大哥相同,那么可以把这两个帮派合成一个帮派

查:假如查一个人的大佬是别人,别人的大佬又是别人......直到有一个人的大佬是自己,那么这个人就是这个集合的大佬

集:集合,每个帮派是一个集合。有多少个集合就是有多少个帮派。

 

Gdufe_2018_Summer I (R)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

题解:先输入测试的样例的个数T,然后输入人的个数N和关系的个数M,最后输入M个关系

这个要我们求的是一共有多少个帮派

import java.util.Scanner;

public class Main {
	static int[] arr = new int[1005];
	static Scanner scan = new Scanner(System.in);
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		int num = scan.nextInt();
		for(int x=0;x<num;x++){
			int n = scan.nextInt();
			int m = scan.nextInt();
			for(int i=0;i<arr.length;i++){
				arr[i] = i;
			}
			for(int o=0;o<m;o++){
				int a = scan.nextInt();
				int b = scan.nextInt();
				p1(a,b);
			}
			int answer = n;
			for(int i=0;i<arr.length;i++){
				if(arr[i]!=i)
					answer--;
			}
			System.out.println(answer);
		}
	}
	private static void p1(int a, int b) {
		// TODO Auto-generated method stub
		int x = find(a);
		int y = find(b);
		if(x!=y)
			arr[x] = y;
	}
	private static int find(int a) {
		// TODO Auto-generated method stub
		if(arr[a]==a)
			return a;
		return find(arr[a]);
	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值