Card Trick(模拟)

Card Trick

题目描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:
1. The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
2. Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
3. Three cards are moved one at a time…
4. This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of
the cards for a given number of cards, 1 ≤ n ≤ 13.

输入

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case consists of one line containing the integer n.  1 ≤ n ≤ 13

输出

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入

2
4
5

样例输出

2 1 4 3
3 1 4 5 2

题意描述:

一个人手中有n张扑克牌,然后呢把第一张放到后面,把第二张(也就是当前第一张)放到桌子上,然后把前两张逐个放到后面,把第三张(也就是当前的第一张)放到桌子上,再然后把前三张逐个放到后面,把第四张(也就是当前的第一张)放到桌子上,以此类推,当手中没有扑克牌的时候,桌子上的扑克牌的顺序是1到n,问手中扑克牌最初的顺序

程序代码:

#include<stdio.h>
int main()
{
	int n,i,j,k,t,T;
	int a[15];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=n;i>0;i--)
		{
			a[i]=i;
			for(j=1;j<=i;j++)
			{
				t=a[n];
				for(k=n;k>i;k--)
					a[k]=a[k-1];
				a[i]=t;
			}
		}
		for(i=1;i<=n;i++)
			printf("%d ",a[i]);
		printf("\n");
	}
	return 0;
}

程序代码

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

贺志营

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值