大数 A + B 【杭电-HDOJ-1002】 附题

/*
A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210207    Accepted Submission(s): 40482


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
#define N 1000
int main(){
	int n;
		while(~scanf("%d",&n)){
			//吞掉回车符 
		      getchar();
		      int i,j,k,a,b,t;
		     //数组定义 
	         char schar1[N+10];
	         char schar2[N+10];
	         int sint1[N+10];
	         int sint2[N+10];
		     for(k=1;k<=n;k++){
			 	memset(sint1,0,sizeof(sint1));//只能初始化int型 
                memset(sint2,0,sizeof(sint2));   	
		     	scanf("%s %s",schar1,schar2);
		        a=strlen(schar1);
		        b=strlen(schar2);
		       
		        //反转赋值 
		        for(i=0; i<a; i++)
		            sint1[a-1-i]=schar1[i]-'0';//一层循环 
		        
		        for(i=0; i<b; i++)
		            sint2[b-1-i]=schar2[i]-'0';
		        //将a定义为a,b中最大的 
		        if(a<b){
		        	t=a;
		        	a=b;
		        	b=t;
		        }
		        //判断是否进位 
		        for(i=0;i<=a;i++){
			       sint1[i]+=sint2[i];
			       if(sint1[i]>9){
			 	      sint1[i]-=10;
				      sint1[i+1]++;      //此处不是i++ 
			       }
		        }
						     
		   	    printf("Case %d:\n%s + %s = ",k,schar1,schar2);
		   	    //判断是否有进位,不同情况不同输出 
                if(sint1[a]==0){
				    for(i=a-1;i>=0;i--)       //逆序输出 
                        printf("%d",sint1[i]); 
                        printf("\n");       //这个printf不在for循环内部     
                }    				
                if(sint1[a]!=0){
                	for(i=a;i>=0;i--)
                        printf("%d",sint1[i]);
                        printf("\n");      //这个printf不在for循环内部 
                }                 
                if(k!=n) printf("\n");   //最后一个不换行             
			 }
	    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值