无心云

云无心以出岫,鸟倦飞而知还。

如何在ubuntu下使用eclipse cdt8.0

这两天将公司的电脑从windows换到了ubuntu,然后装了一个 eclipse cdt 8.0,结果发现根本无法使用,它无法识别c++以及c的头文件,这一点很奇怪,因为我在 windows下使用的时候是没有任何问题的,那么到底是怎么回事呢?原来问题出在了gnu环境下的两个环境变量上

C_INCLUDE_PATH:表示gcc默认使用的 include路径

CPLUS_INCLUDE_PATH:表示g++默认使用的include路径

只需要将两个路径设置对就可以,

CPLUS_INCLUDE_PATH: usr/include/c++/4.6.1:/usr/include/c++/4.6.1/tr1:/usr/include/c++/4.6.1/x86_64-linux-gnu

C_INCLUDE_PATH:/usr/include:/usr/include/linux:/usr/include/x86_64-linux-gnu


另外cdt8.0使用了一个叫 code anylyser的东西,这个东西想法很好,但是目前 应该 还是处于实验阶段,但是比较操蛋的是,cdt8.0居然默认把它打开了,

因此原来的程序一旦放进去就显示各种错误,最后不得不把它给关了。

阅读更多
个人分类: c/c++相关
想对作者说点什么? 我来说一句

Ubuntu下开发Eclipse下的Hadoop应用

2013年04月12日 2.63MB 下载

Eclipse使用VSS

2009年01月12日 61KB 下载

android源码编译

2012年04月10日 397KB 下载

GEMS-Ubuntu.pdf

2011年07月07日 552KB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭