Quoit Design ————分治与归并(平面分治模板)

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
Sample Output
0.71
0.00
0.75


白书上的模板

#include<bits/stdc++.h>
using namespace std;
typedef pair<double,double> P;
const int MAXN=100005;
const int INF=0x3f3f3f3f;
int n;
P A[MAXN];
bool compare_y(P a,P b)
{
    return a.second<b.second;
 } 
double closest_pair(P *a,int n)
{
    if(n<=1)    return INF;
    int m=n/2;
    double x=a[m].first;
    double d=min(closest_pair(a,m),closest_pair(a+m,n-m));
    inplace_merge(a,a+m,a+n,compare_y);
    vector<P> b;
    for(int i=0;i<n;i++)
    {
        if(fabs(a[i].first-x)>=d)   continue;
        for(int j=0;j<b.size();j++)
        {
            double dx=a[i].first-b[b.size()-j-1].first;
            double dy=a[i].second-b[b.size()-j-1].second;
            if(dy >= d) break;
            d=min(d,sqrt(dx*dx+dy*dy));
        }   
        b.push_back(a[i]);
    } 
    return d;   
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%lf %lf",&A[i].first,&A[i].second);
        sort(A,A+n);
        printf("%.2lf\n",closest_pair(A,n)/2.0);
    }
    return 0;
}

另外一种代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<string>
#define long long LL
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define lson o<<1
#define rson o<<1|1
using namespace std;
struct node{
    double x, y;
}a[100005];
double Min(double x, double y)
{
    if(x > y)
        return y;
    return x;
}
bool cmpx(node a, node b)
{
    return a.x < b.x;   
} 
bool cmpy(node l, node r)
{
    return l.y < r.y;
}
double Cal_dis(node c, node d)
{
    return sqrt((c.x - d.x) * (c.x - d.x) + (c.y - d.y) * (c.y - d.y));
}
double Short_dis(int l, int r)
{
    double d = 100000;
    if(l == r)
        return d;
    else if(l + 1 == r)
        return Cal_dis(a[l], a[r]);
    int mid = (l + r) >> 1;
    d = Min(Short_dis(l, mid), Short_dis(mid + 1, r));
    int i = l, j = r;
    while(i < mid && a[mid].x - a[i].x >=d) i++;
    while(j > mid && a[j].x - a[mid].x >=d) j--;
    sort(a + i + 1, a + j + 1, cmpy);
    for(int k = i; k <= j; k++)
    {
        for(int m = k + 1;m <= j && a[m].y - a[k].y < d; m++)
        {
            double D = Cal_dis(a[m], a[k]);
            if(d > D)
                d = D;
        }
    }
    return d;
}
int main()
{
    int N;
    while(cin >> N && N)
    {
        for(int i = 1; i <= N; i++)
            scanf("%lf %lf", &a[i].x, &a[i].y);
        sort(a + 1, a + N + 1, cmpx);
        double ans = Short_dis(1, N);
        if(ans >= 100000)
            puts("INFINITY");
        else
            printf("%.2lf\n", ans/2.0);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值