Super Jumping! Jumping! Jumping!——————LIS的最大和

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
这里写图片描述
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3


思路:

  • 让我们找连续递增子序列的最大和,刚开始想的是找到最大连续递增子序列(LIS)
  • 然后递归找到LIS的每一个元素让其相加
  • 可是想到了有时候会出现其序列并不是最长的,但是他们的和却最大比如, 60,70,1,2,3,4 60 , 70 , 1 , 2 , 3 , 4 它们的和最大值是 60+70 60 + 70 而不是 1+2+3+4 1 + 2 + 3 + 4 ,所以我们找的时候并不能直接找最长递增子序列

dp[i]:=a[i] d p [ i ] := 以 a [ i ] 为 结 尾 的 最 长 上 升 子 序 列 的 和

那么状态转移方程就是:

dp[i]={max{dp[i],dp[j]+a[i]}max{dp[i],a[i]}a[i]>a[j]else d p [ i ] = { m a x { d p [ i ] , d p [ j ] + a [ i ] } a [ i ] > a [ j ] m a x { d p [ i ] , a [ i ] } e l s e


那么我们很容易就能够写出瞎编的程序了
哦不,下边的程序

#include<bits/stdc++.h>
using namespace std;
const int MAXN=10005;
const int INF=0x3f3f3f3f;
int a[MAXN];
int dp[MAXN];

int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        int ans=-INF;
        memset(dp,0,sizeof(dp));
        dp[0]=a[0];
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<i;j++)
                if(a[i]>a[j])   dp[i]=max(dp[i],dp[j]+a[i]);
                else            dp[i]=max(dp[i],a[i]);
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值