PAT甲级1044 Shopping in Mars (25 分)【二分查找】

35 篇文章 0 订阅

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题意:给一串数字,要求连续的数字和最接近题目所给的,然后输出符合的序列的头和尾

解题思路:直接模拟肯定超时,头和尾我们可以用结构体来存储,符合的就压进去结构数组,其中求答案用二分法来查找符合的。sum[i]是表示1到i的和,如果要算i到j的和就等于sum[j]-sum[i-1] ,不清楚的可以自己试试,我们要求的是头和尾嘛,所以我们就按照头的顺序来慢慢找(sum数组是升序的),从1开始找最接近m的,其中找最接近m时,用二分法查找,然后从2开始找,一直到n,每一次我们用sum[low]-sum[i-1]跟mini比较,如果比mini小的话,mini更新,那之前压进结构体数组的肯定要clear喽,把i,low压进结构数组,如果等于mini的话我们就把i,low压进去就好了,最后把答案按照题目要求输出就ok啦。

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
struct ans{
	int x,y;
};
int sum[100010]={0};
int main(void)
{
	int n,m,a,b,mini=0x3f3f3f3f;
	scanf("%d %d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a);
		sum[i]+=sum[i-1]+a; 
	}
	vector<ans>v;
	for(int i=1;i<=n;i++)
	{
		int low=i,high=n,mid;
		while(low<=high)//从i开始的序列查找最接近m的
		{
			mid=(low+high)/2;
			if(sum[mid]-sum[i-1]>=m) high=mid-1;
			else low=mid+1;
		}
		if(sum[low]-sum[i-1]>=m)
		{
			if(sum[low]-sum[i-1]<mini) 
			{
				mini=sum[low]-sum[i-1];
				v.clear();
				v.push_back({i,low});
			}
			else if(sum[low]-sum[i-1]==mini)
			{
				v.push_back({i,low});
			}
		}
		
	}
	for(int i=0;i<v.size();i++)
	printf("%d-%d\n",v[i].x,v[i].y);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值