2018.湘潭邀请赛.F.2018

F.  Sorting

Problem Description

Bobo has n tuples (a1,b1,c1),(a2,b2,c2),...,(an,bn,cn). He would like to find the lexicographically smallest permutation p1,p2,...pn of 1,2,...,n such that for i {2,3,...,n} it holds that

Input

The input consists of several test cases and is terminated by end-of-file.

The first line of each test case contains an integer n. The i-th of the following n lines contains contains 3 inteegers ai,bi,ci.

output

For each test case, print n integers p1,p2,...,pn seperated by spaces. DO NOT print trailing spaces.

Constraint

1<=n<=10^3

1<=ai,bi,ci<=2*10^9

The sum of n does not exceed 10^4

Sample Input

2

1 1 1

1 1 2

2

1 1 2

1 1 1

3

1 3 1

2 2 1

3 1 1

Sample Output

2 1

1 2

1 2 3


题意:
有n个三元组,下标依次为1至n,给出三元组排序的方式
求出所代表分数,求解最小字典序的排列方式

思路:
式子可以化简为,( a(i-1) + b(i-1) * c(i) <= ( a(i) + b(i) ) * c(i-1) )
数据比较小,冒泡排序一遍即可

#include <iostream>
#include <cstdio>
using namespace std;
#define LL long long
#define N 2005
struct node
{
	LL a,b,c;
}no[N]; 
int ans[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF) {
    	for(int i=1;i<=n;i++) {
    		ans[i] = i;
    		scanf("%lld%lld%lld",&no[i].a,&no[i].b,&no[i].c);
    	} 
    	for(int i=1;i<n;i++) {
    		for(int j=i+1;j<=n;j++) {
    			if( (no[j].a + no[j].b) * no[i].c <  (no[i].a + no[i].b) * no[j].c ) //冒泡排序
			         swap(ans[i],ans[j]);
    			else if( (no[j].a + no[j].b) * no[i].c ==  (no[i].a + no[i].b) * no[j].c){ //如果相等,则下标小的优先
    				if(ans[j] < ans[i])
						swap(ans[i],ans[j]);
    			} 
    		}
    	}
    	for(int i=1;i<=n;i++) printf(i==1?"%d":" %d",ans[i]);
    	puts("");
    }
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值