POJ.1011 Sticks

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 149197 Accepted: 35430

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

AC代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int Max = 65;
int n, len, stick[Max];
bool flag, vis[Max];

bool cmp(int a, int b)
{
    return a > b;
}

void dfs(int dep, int now_len, int u)    // dep为当前已被用过的小棒数,now_len表示现在的长度,u为当前要处理的小棒。
{
    if(flag) return;//如果找到了就返回
    if(now_len == 0)                     //  当前长度为0,寻找下一个当前最长小棒。
    {
        int k = 0;//从第一个树枝开始寻找
        while(vis[k]) k ++;              //  寻找第一个当前未被选中的最长小棒。
        vis[k] = true;                   //置为选中
        dfs(dep + 1, stick[k], k + 1);
        vis[k] = false;
        return;
    }
    if(now_len == len)                   //  当前长度为len,即又拼凑成了一根原棒。
    {
        if(dep == n) flag = true;        //  完成的标志:所有的n根小棒都有拼到了。
        else dfs(dep, 0, 0);            //表示找到了一组但是没有找全
        return;
    }
    for(int i = u; i < n; i ++)
        if(!vis[i] && now_len + stick[i] <= len)
        {
            if(!vis[i-1] && stick[i] == stick[i-1]) continue;      //  不重复搜索:最重要的剪枝。(如果之前的树枝和现在的一样长并且没有被选中也就是无法实现组合,那么现在的这根也是一样的不需要重复一遍操作)
            vis[i] = true;                                         //之前的那根木棍如果未访问说明他无法在当前组里组合,则下面的和他一样的也不会形成组合
            dfs(dep + 1, now_len + stick[i], i + 1);
            vis[i] = false;
        }
}

int main()
{
    while(scanf("%d", &n) && n != 0)
    {
        int sum = 0;
        flag = false;
        for(int i = 0; i < n; i ++)
        {
            scanf("%d", &stick[i]);
            sum += stick[i];
        }
        sort(stick, stick + n, cmp);     //  从大到小排序。
        for(len = stick[0]; len < sum; len ++)
            if(sum % len == 0)           //  枚举能被sum整除的长度,即可以被刚好分开
            {
                memset(vis, 0, sizeof(vis));//表示都没有被选中
                dfs(0, 0, 0);
                if(flag) break;//表示已经找到了
            }
        printf("%d\n", len);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎曼猜想·

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值