1136 A Delayed Palindrome (20分)

该程序实现了一个寻找大整数配对回文数的过程。输入一个正整数,如果该数本身就是回文数,则直接输出;如果不是,通过不断将数与其反转数相加,直至得到回文数或超过10次迭代,若10次内未找到回文数则输出"Not found in 10 iterations."。示例中展示了对于97152和196两个数的处理过程。
摘要由CSDN通过智能技术生成

Consider a positive integer N written in standard notation with k+1 digits a
​i
​​ as a
​k
​​ ⋯a
​1
​​ a
​0
​​ with 0≤a
​i
​​ <10 for all i and a
​k
​​ >0. Then N is palindromic if and only if a
​i
​​ =a
​k−i
​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

大整数加法,以后再练练,太久没做了忘记了。
reverse之后可以直接比较,不需要一位一位比

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

bool isPalindromic(string a){
    string b =a;
    reverse(a.begin(),a.end());
    if(a == b) return true;
    return false;
}

string jia(string a){
    string b = a;
    string sum = a;;
    reverse(a.begin(),a.end());
    int carry = 0;
    for(int i = a.length()-1; i>=0; i--){
        sum[i] = (a[i] - '0' + b[i] - '0' + carry) % 10 + '0';
        carry = (a[i] - '0' + b[i] - '0' + carry)/10;
    }
    if(carry == 1) sum = '1' + sum;
    cout<<b<<" + "<<a<<" = "<<sum<<endl;
    return sum;
}

int main(){
    string a;
    int ite = 0;
    cin>>a;
    if(isPalindromic(a)){
        cout<<a<<" is a palindromic number.";
        return 0;
    }
    while(ite++<10){
        a = jia(a);
        if(isPalindromic(a)){
            cout<<a<<" is a palindromic number.";
            return 0;
        }
    }
    cout<<"Not found in 10 iterations.";
    return 0;
}

二刷,还行

#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
bool isPalin(string a){
    string b = a;
    reverse(a.begin(), a.end());
    if(a==b) return true;
    return false;
}
string jia(string a){
    string sum = a;
    string b = a;
    reverse(a.begin(),a.end());
    int carry = 0;
    for(int i = a.length()-1; i >= 0; i--){
        sum[i] = (a[i] -'0' + b[i] - '0' + carry)%10+'0';
        carry = (a[i]-'0'+b[i] -'0'+carry)/10;
    }
    if(carry == 1) sum = '1'+sum;
    cout<<b<<" + "<<a<<" = "<<sum<<endl;
    return sum;
}

int main(){
    string a;
    int i;
    cin>>a;
    for(i = 0 ; i < 10; i++){
        if(isPalin(a)) break;
        a = jia(a);
        
    }
    if(i==10) cout<<"Not found in 10 iterations.";
    else cout<<a<<" is a palindromic number.";
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值