hdoj 2141 can you find it ?

Can you find it?


Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 


Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input

  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

  
  
Case 1: NO YES NO
解题思路:用二分法先求出两个数的和,然后排序,进行二分。控制好输入和输出。
<span style="font-size:14px;">#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[510],b[510],c[510],num[250100];
int main()
{
    int m,n,t,i,j,k,con=1;
    while(scanf("%d%d%d",&m,&n,&t)!=EOF)
    {
        
        for(i=0;i<m;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)
            scanf("%d",&b[i]);
        for(i=0;i<t;i++)
            scanf("%d",&c[i]);
    int q=0;
    for(i=0;i<m;i++)
    {
            for(j=0;j<n;j++)
            num[q++]=a[i]+b[j];
    }
    sort(num,num+q);
    scanf("%d",&k);
    printf("Case %d:\n",con++);
    while(k--)
    {
        int flag=0;
        int max;
        scanf("%d",&max);
        for(i=0;i<t;i++)
        {
            int ans=max-c[i];
            int left=0,right=q-1,mid;
            while(right>=left)
            {
                mid=(left+right)/2;
                if(num[mid]>ans) 
                    right=mid-1;
                else if(num[mid]<ans)
                    left=mid+1;
                else
                {
                    flag=1;
                    break;
                }
            }
            if(flag)
                break;
        }
            if(flag)
                {    
                    printf("YES\n");
                }
            else
                    printf("NO\n");                        
        }            
    }
    return 0;
}  </span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值