#尺取法# 尺取法总结和经典例题

题目链接:POJ3061 Subsequence
题目链接:Educational Codeforces Round 11C. Hard Process
题目链接:UVA11572 - Unique Snowflakes

POJ3061 Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

Description:

给长度为n的数组和一个整数s,求总和不小于s的连续子序列的最小长度

Solution:

尺取法

尺取法的思路:

反复地推进区间的开头和末尾,来求取满足条件的最小区间的方法被称为尺取法( O(n) )

  1. 以 l = r = sum = 0 初始化
  2. 只要依然有sum < s,就不断将sum增加ar,并将r增加1
  3. 如果第2步无法满足sum >= s则终止,否则更新ans = min(ans, r - l);
  4. 将sum减去al,l增加1然后回到第2步

样例1查找过程:

Code:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
typedef long long LL;
using namespace std;
const int MaxN = 3e5 + 5;

int a[MaxN];

int main() {
   
	int t, n, s;
    scanf("%d", &t);
    while(t--) {
   
        scanf("%d %d",&n, &</
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值