Raucous Rockers~

Raucous Rockers

You just inherited the rights to N (1 <= N <= 20) previously unreleased songs recorded by the popular group Raucous Rockers. You plan to release a set of M (1 <= M <= 20) compact disks with a selection of these songs. Each disk can hold a maximum of T (1 <= T <= 20) minutes of music, and a song can not overlap from one disk to another.

Since you are a classical music fan and have no way to judge the artistic merits of these songs, you decide on the following criteria for making the selection:

  • The songs on the set of disks must appear in the order of the dates that they were written.
  • The total number of songs included will be maximized.

PROGRAM NAME: rockers

INPUT FORMAT

Line 1:Three integers: N, T, and M.
Line 2:N integers that are the lengths of the songs ordered by the date they were written.

SAMPLE INPUT (file rockers.in)

4 5 2
4 3 4 2

OUTPUT FORMAT

A single line with an integer that is the number of songs that will fit on M disks.

SAMPLE OUTPUT (file rockers.out)

3
题意:给你 m 张光盘,每个光盘最多只能刻 t 分钟,现在你有 n 首歌,求最多可以刻多少歌,歌的顺序不能改变。
分析:状态压缩或直接DFS
方法一:状态压缩
View Code
复制代码
/*
  ID: dizzy_l1
  LANG: C++
  TASK: rockers
*/
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

int a[21],p[21],v[21];
int n,t,m,cnt,ans,tans;

bool judge()
{
    int i,j;
    for(i=0;i<m;i++) v[i]=t;
    for(i=0,j=0;i<cnt;i++)
    {
        if(a[p[i]]>t) return false;
        if(a[p[i]]<=v[j]) v[j]-=a[p[i]];
        else
        {
            j++;
            v[j]-=a[p[i]];
        }
        if(j==m) return false;
    }
    return true;
}

void work(int x)
{
    int tx,i;
    tx=x;
    while(tx)
    {
        i=tx&(-tx);
        tx^=i;
        i=log2(i*1.0);
        p[cnt++]=i;
    }
    if(cnt<=ans) return ;
    if(judge()) ans=cnt;
}

int main()
{
    freopen("rockers.in","r",stdin);
    freopen("rockers.out","w",stdout);
    int nn,i;
    while(scanf("%d%d%d",&n,&t,&m)==3)
    {
        for(i=0;i<n;i++) scanf("%d",&a[i]);
        nn=pow(2,n);
        ans=0;
        for(i=1;i<=nn-1;i++)
        {
            cnt=0;
            work(i);
        }
        printf("%d\n",ans);
    }
    return 0;
}
复制代码

方法二:DFS

View Code
复制代码
 #include<iostream>
 #include<fstream>
 #include<cstdio>
 #include <time.h>
 #define N 21
 using namespace std;
 
 int ans,max,a[N],b[N],n,t,m;
 
 void work(int k,int i,int r)
 {
     if(k==m||i==n)
     {
         if(ans<max) ans=max;
         return ;
     }
     if(max+r<=ans) return ;//减的巧呀!!!
     if(b[k]>=a[i])
     {
         b[k]-=a[i];
         max++;
         work(k,i+1,r-1);
         max--;
         b[k]+=a[i];
         work(k,i+1,r-1);
     }
     else 
     {
         work(k+1,i,r);
         work(k,i+1,r-1);    
     }
 }
 
 int main()
 {
 //    freopen("E.txt","r",stdin);
 //    freopen("out.txt","w",stdout);
     int i;
     while(cin>>n>>t>>m)
     {
         max=ans=0;
         for(i=0;i<n;i++) 
         {
             cin>>a[i];        
         }
         for(i=0;i<m;i++) b[i]=t;
         work(0,0,n);
         cout<<ans<<endl;
     }
 //    cout<<(double)clock()/CLOCKS_PER_SEC<<endl;
     return 0;
 }
复制代码

 方法三:dp

d[a][b][c]  表示第 a 个光盘已经使用了 b 分钟最后一首歌是 c。

d[ a ][ b+length[d] ][ d ] =max(d[a][b][c]+1 , d[ a ][ b+length[d] ][ d ])

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值