九度OJ 1001

66 篇文章 1 订阅
27 篇文章 0 订阅
题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5

题目大意:计算A+B矩阵之和,假设和为矩阵C,输出C矩阵中元素全为0的行数和列数。 只有每行或者每列全为0,才能计数加1

思路:声明两个矩阵A,B,首先将它们之和的矩阵放入矩阵C,然后对C矩阵每行进行判断,遇到非0值的话,就跳过进行下一行的判断,只有一行全部为0才能计数,具体来说,就是j的值到了最后一列,并且此时flag的值还保持为true,说明前面的值全为0. 然后再进行按列进行判断,即可。

#include <iostream>
using namespace std;

const int MAX = 11;

int main(){
    int N,M;
    int A[MAX][MAX],B[MAX][MAX];
    while(cin>>N){
        if(N == 0)
            break;
        cin>>M;
        int index = 0;
        bool flag = 1;
        for(int i=1;i<=N;i++){
            for(int j=1;j<=M;j++)
                cin>>A[i][j];
        }
        for(int i=1;i<=N;i++){
            for(int j=1;j<=M;j++)
                cin>>B[i][j];
        }
        for(int i=1;i<=N;i++){
            for(int j=1;j<=M;j++)
                A[i][j] = A[i][j] + B[i][j];
        }
        for(int i=1;i<=N;i++){
            flag = 1;
            for(int j=1;j<=M;j++){
                if(A[i][j] != 0){
                    flag = false;
                    break;
                }
                if((j == M)&&(flag == true))
                    index ++;
            }
        }
        for(int i=1;i<=M;i++){
            flag = 1;
            for(int j=1;j<=N;j++){
                if(A[j][i] != 0){
                    flag = false;
                    break;
                }
                if((j == N)&&(flag == true))
                    index ++;
            }
        }
        cout<<index<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值