PAT甲 1009. Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
 
 
 
 
题目的意思是多项式乘法 样例是(2.4*x^1+3.2*x^0)*(1.5*x^2+0.5*x^1)=(3.6*x^3+6.0*x^2+1.6*x^1)
 
 
 
 
 
 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;

struct node
{
    int k;
    double a;
}a[15],b[15];
double s[10004];
int main()
{
    int n,m;
    memset(s,0,sizeof(s));

    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d%lf",&a[i].k,&a[i].a);
    }
     scanf("%d",&m);
    for(int i=0;i<m;i++)
    {
        scanf("%d%lf",&b[i].k,&b[i].a);
    }
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
    {
        s[a[i].k+b[j].k]+=a[i].a*b[j].a;
    }
int cnt=0;
    for(int i=0;i<=a[0].k+b[0].k;i++)
        if(s[i]!=0)
        cnt++;
    printf("%d",cnt);
    for(int i=a[0].k+b[0].k;i>=0;i--)
    {
        if(s[i]!=0)
            printf(" %d %.1f",i,s[i]);
    }
    printf("\n");

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值