Hdu1695 GCD

7 篇文章 0 订阅
6 篇文章 0 订阅

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11177    Accepted Submission(s): 4236


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:   1689  1690  1693  1691  1698 


——————————————————————————————————
题目的意思是给出两个区间,问两个区间有多少对数GCD=k,(1,2)和(2,1)算一种,区间从1开始

思路:先把区间每个数除以k,然后说白了就是求[1,m/k],[1,n/k]有多少对数互质 可以枚举m/k,在n/k中找有多少互质的数,可以先把枚举的m/k质因数的分解,然后利用容斥定理计数,防止重复计数枚举时可以计算i与区间[i,n/k]的互质数;
防止超时分解的质因数可以先打个表
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<string>
#include<queue>
#include<stack>
#include<map>
#include<set>
using namespace std;
#define LL long long
const int inf=0x3f3f3f3f;

vector<LL>p[100010];
int pr[100010];
int a,b,x,y,k;
LL ans;

void init()
{
    memset(pr,0,sizeof pr);
    for(int i=1;i<=100005;i++) p[i].clear();
    for(int i=2;i<=100005;i+=2)
        p[i].push_back(2);
    for(int i=3;i<=100005;i+=2)
    {
        if(!pr[i])
        {
            for(int j=i;j<=100005;j+=i)
            {
                pr[j]=1;
                p[j].push_back(i);
            }

        }
    }
}

void dfs(int no,int pos,int xx,int cnt)
{
    if(pos>=p[no].size())
    {
        if(cnt==0)
            return;
        if(cnt%2)
        {
            ans+=y/xx;
            ans-=(no-1)/xx;
        }
        else
        {
            ans-=y/xx;
            ans+=(no-1)/xx;
        }
        return;
    }
    dfs(no,pos+1,xx*p[no][pos],cnt+1);
    dfs(no,pos+1,xx,cnt);
}

int main()
{
    init();
    int T;
    int q=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d",&a,&x,&b,&y,&k);
          if (k == 0) {
            printf("Case %d: 0\n", q++);
            continue;
        }
        x/=k,y/=k;
        if(x>y) swap(x,y);
        LL ans2=0;
        for(int i=1; i<=x; i++)
        {
            ans=0;
            dfs(i,0,1,0);
            ans2+=y-i+1-ans;
        }
        printf("Case %d: %lld\n",q++,ans2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值