HDU5810 Balls and Boxes

7 篇文章 0 订阅

Balls and Boxes

                                                                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                                                 Total Submission(s): 797    Accepted Submission(s): 526


Problem Description
Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After the experiment, he calculated the statistical variance V as
V=mi=1(XiX¯)2m

where  Xi  is the number of balls in the ith box, and  X¯  is the average number of balls in a box.
Your task is to find out the expected value of V.
 

Input
The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.
The input is terminated by n = m = 0.
 

Output
For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.
 

Sample Input
  
  
2 1 2 2 0 0
 

Sample Output
  
  
0/1 1/2
Hint
In the second sample, there are four possible outcomes, two outcomes with V = 0 and two outcomes with V = 1.
 

Author
SYSU
 

Source
—————————————————————————————————
题意: 把n个球放到m个盒子里面,求上面这个式子的期望;
思路:打表找规律,发现答案=n*(m-1)/m*m 求gcd即可
证明:
E(V)=1/m*E(∑(x i-x) 2)=E((x-n/m) 2)=E(x 2)-2*n/m*E(x)+n 2/m 2
E(x)=n/m;E(x 2)=D(x)+[E(x)] 2;变成二项分布了,D(x)=n*(m-1)/m 2
所以带到上面的式子中就变成了E(v)=n*(m-1)/m 2

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

LL n,m;

LL gcd(LL x,LL y)
{
    return x?gcd(y%x,x):y;
}

int main()
{
    while(~scanf("%lld%lld",&n,&m)&&(n+m))
    {
        if(m==1) {printf("0/1\n");continue;}
        n=(m-1)*n;
        m=m*m;
        printf("%lld/%lld\n",n/gcd(n,m),m/gcd(n,m));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值