1085. Perfect Sequence (25)

1085. Perfect Sequence (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

得先看明白题意,minimum number是可以变化的,maximum  number也可以随着minimum number的增大而增大,找到满足maximum number < minimum number * p所跨的线性表最大长度。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
	int i,N,p;
	int num;
	vector<long int> s;//要考虑N的范围
	cin>>N>>p;
	for(i=0;i<N;i++){
		cin>>num;
		s.push_back(num);	
	}
	sort(s.begin(),s.end());//排序
	int begin=0,last=0,maximun=0;
	while(last<N){
		while(last<N && s[last]<=s[begin]*p){
			last++;	
		}
		if(maximun<last-begin)//最大长度记录及更新
			maximun=last-begin;
		begin++;	//最小数的变化
	}
	cout<<maximun<<endl;
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值