05-树6. Path in a Heap (25)

05-树6. Path in a Heap (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

Insert a sequence of given numbers into an initially empty min-heap H. Then for any given index i, you are supposed to print the path from H[i] to the root.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (<=1000) which are the size of the input sequence, and the number of indices to be checked, respectively. Given in the next line are the N integers in [-10000, 10000] which are supposed to be inserted into an initially empty min-heap. Finally in the last line, M indices are given.

Output Specification:

For each index i in the input, print in one line the numbers visited along the path from H[i] to the root of the heap. The numbers are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
5 3
46 23 26 24 10
5 4 3
Sample Output:
24 23 10
46 23 10
26 10

最小堆,是完全二叉树的结构,且每个元素的值不大于其子节点的元素值。

#include<iostream>
using namespace std;

struct HeapStruct{
	int *data;
	int size;
	int capacity;
};

HeapStruct *Create(int maxsize)		//创建最小堆 
{
	HeapStruct *H=new HeapStruct;
	H->data=new int[maxsize+1];
	H->size=0;
	H->capacity=maxsize;
	H->data[0]=-10001;
	return H;
}

void Insert(HeapStruct *H,int item)		//将元素插入堆中 
{
	int i;
	if(H->size == H->capacity){
		return;
	}
	i=++H->size;				//不能码成H->size++...T_T
	for(;H->data[i/2]>item;i/=2){
		H->data[i]=H->data[i/2];
	}
	H->data[i]=item;
}

int main()
{
	int i,N,M;
	cin>>N>>M;
	HeapStruct *MinHeap=Create(N);
	for(i=0;i<N;i++){
		int num;
		cin>>num;
		Insert(MinHeap,num);
	}
	int c[M];
	for(i=0;i<M;i++)
		cin>>c[i];
	for(i=0;i<M;i++){
		int index=c[i];
		while(index>0){
			cout<<MinHeap->data[index];
			if(index>1)
				cout<<" ";		
			index/=2;
		}
		cout<<endl;
	}
	return 0;
}


import heapq import copy # 定义状态类 class State: def __init__(self, board, moves=0, parent=None, last_move=None): self.board = board self.moves = moves self.parent = parent self.last_move = last_move def __lt__(self, other): return self.moves < other.moves def __eq__(self, other): return self.board == other.board # 定义转移函数 def move(state, direction): new_board = copy.deepcopy(state.board) for i in range(len(new_board)): if 0 in new_board[i]: j = new_board[i].index(0) break if direction == "up": if i == 0: return None else: new_board[i][j], new_board[i-1][j] = new_board[i-1][j], new_board[i][j] elif direction == "down": if i == len(new_board)-1: return None else: new_board[i][j], new_board[i+1][j] = new_board[i+1][j], new_board[i][j] elif direction == "left": if j == 0: return None else: new_board[i][j], new_board[i][j-1] = new_board[i][j-1], new_board[i][j] elif direction == "right": if j == len(new_board)-1: return None else: new_board[i][j], new_board[i][j+1] = new_board[i][j+1], new_board[i][j] return State(new_board, state.moves+1, state, direction) # 定义A*算法 def astar(start, goal): heap = [] closed = set() heapq.heappush(heap, start) while heap: state = heapq.heappop(heap) if state.board == goal: path = [] while state.parent: path.append(state) state = state.parent path.append(state) return path[::-1] closed.add(state) for direction in ["up", "down", "left", "right"]: child = move(state, direction) if child is None: continue if child in closed: continue if child not in heap: heapq.heappush(heap, child) else: for i, (p, c) in enumerate(heap): if c == child and p.moves > child.moves: heap[i] = (child, child) heapq.heapify(heap) # 测试 start_board = [[1, 2, 3], [4, 5, 6], [7, 8, 0]] goal_board = [[2, 3, 6], [1, 5, 8], [4, 7, 0]] start_state = State(start_board) goal_state = State(goal_board) path = astar(start_state, goal_board) for state in path: print(state.board) 这段代码运行后报错,因为State是不可hash的,那么如何修改才能使得功能一样且能够运行
最新发布
03-27
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值