Tempter of the Bone(树的直径)

Link:https://cn.vjudge.net/contest/174968#problem/B

题目:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0

Sample Output

NO
YES

解题:

搜索题,一直是我棘手的问题。本题涉及到深度搜索(当然也可以广度搜索)+剪枝,典型的迷宫问题。问题的大概意思是,狗在S点,门在D点,门只有在T时刻才开,迷宫为N*M矩阵,迷宫内有X代表的墙。问是否狗能准时逃出来。我们要制造一个计划,让狗能在T时刻刚好到达门口,一般思路可以来回走动,快到T时候再到门口。但是题目要求狗每次走的地方都将会陷下去,不能回走,只能绕路走,能绕路走可定要多出偶数的步数,就算是墙挡着也一样如此,可以看草图:

这里写图片描述

两种不同的走法,下面那一种可以控制时间刚好在T时刻。因为差出的是偶数,所以奇数的话要剪枝掉,省掉搜索时间。而另一个剪枝,路径剪枝,是在开始的时候,将如迷宫的每个地方都走过了,而还没到门开的时间,这时也逃生不了,因为没地方回走了,都塌陷了。
深度搜索下去,直到所用的步数刚好等于给定的T时间,退出递归搜索。

Code:

#include <iostream>  
using namespace std;  
char map[9][9];        //地图最多不超过7行7列,又从(1,1)计算,所以开辟9,9  
int n,m,t,di,dj;       //给定的三个量,以及终点位置  
bool escape;           //标识逃生成功  
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};  //分别表示左、右、下、上四个方向  
void DFS(int si,int sj,int cnt)  
{  
    int i,temp;  
    if (si>n || sj>m || si<=0 || sj<=0)   //越出边界便不搜索  
        return;  
    if (si==di && sj==dj && cnt==t)  
    {  
        escape=1;                   //时间正好的时候才能逃生  
        return;  
    }  
    temp=abs(t-cnt)-(abs(di-si)+abs(dj-sj));     //计算当前到终点的最短路与还需要的时间差,若小于0则路径剪枝  
    if (temp<0 || temp&1)           //temp如果是奇数的话也要剪枝  
        return;  
    for (i=0;i<4;i++)  
    {  
        if (map[si+dir[i][0]][sj+dir[i][1]]!='X')  
        {  
            map[si+dir[i][0]][sj+dir[i][1]]='X';  //把当前点刷为X  
            DFS(si+dir[i][0],sj+dir[i][1],cnt+1); //搜索该点              
            if (escape)  
                return;  
            map[si+dir[i][0]][sj+dir[i][1]]='.';  //如果搜索不到退出来了,则重新把该点刷为'.'  
        }  
    }  
    return ;  
}  
int main()  
{  
    int i,j,si,sj,wall;  
    while (cin>>n>>m>>t)  
    {  
        if (n==0 && m==0 && t==0)  
        {  
            break;  
        }  
        wall=0;  
        for (i=1;i<=n;i++)  
        {  
            for (j=1;j<=m;j++)  
            {  
                cin>>map[i][j];  
                if (map[i][j]=='S')  
                {  
                    si=i,sj=j;  
                }  
                else if (map[i][j]=='D')  
                {  
                    di=i,dj=j;  
                }  
                else if (map[i][j]=='X')  
                {  
                    wall++;  
                }  
            }  
        }  
        if (n*m-wall<=t)      //路径剪枝,当走完不含墙的迷宫都还不到T时间将不能逃生  
        {  
            cout<<"NO"<<endl;  
            continue;  
        }  
        escape=0;  
        map[si][sj]='X';      //记得刷为'X'  
        DFS(si,sj,0);  
        if (escape)  
        {  
            cout<<"YES"<<endl;  
        }  
        else  
        {  
            cout<<"NO"<<endl;  
        }  
    }  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值