BestCoder Round #84 1004Dertouzos


Problem Description
A positive proper divisor is a positive divisor of a number n , excluding n itself. For example, 1, 2, and 3 are positive proper divisors of 6, but 6 itself is not.

Peter has two positive integers n and d . He would like to know the number of integers below n whose maximum positive proper divisor is d .
 

Input
There are multiple test cases. The first line of input contains an integer T (1T106) , indicating the number of test cases. For each test case:

The first line contains two integers n and d (2n,d109) .
 

Output
For each test case, output an integer denoting the answer.
 

Sample Input
  
  
9 10 2 10 3 10 4 10 5 10 6 10 7 10 8 10 9 100 13
 

Sample Output
  
  
1 2 1 0 0 0 0 0 4
 


题意: 给你到n的数列,求这里边的数最大非平凡因子(非平凡:不等于1和它本身)为d的个数。

思路:a*d=n(d为n的最大非平凡因子,d<n&&a>1)d=p*p'(p为d的最大非平凡因子,p<d&&p'>1)==> n=a*p*p'   范围:1<a<=p'<=p;根据该范围枚举每一个因子。


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>

using namespace std;

int is[100000 +5];

int ds()
{
    is[0] = 2;
    is[1] = 3;
    int k = 2;
    for(int i = 5; i <= 100000; i++)
    {
        int temp = sqrt(i);
        bool judge = 0;
        for(int j = 2; j <= temp; j++)
            if(i%j == 0)
            {
                judge = 1;
                break;
            }

        if(judge == 0)
            is[k++] = i;
    }
    return k;
}
int main()
{
    int k = ds();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,d,sum = 0;
        scanf("%d%d",&n,&d);
        //int temp = sqrt(d);
        for(int i = 0; is[i] <= d; i++)
        {
            if(is[i]*d < n)
                sum++;
            else
                break;
            if(d%is[i] == 0)          //a<p'
                break;

        }
        printf("%d\n",sum);
    }

}


# 高校智慧校园解决方案摘要 智慧校园解决方案是针对高校信息化建设的核心工程,旨在通过物联网技术实现数字化校园的智能化升级。该方案通过融合计算机技术、网络通信技术、数据库技术和IC卡识别技术,初步实现了校园一卡通系统,进而通过人脸识别技术实现了更精准的校园安全管理、生活管理、教务管理和资源管理。 方案包括多个管理系统:智慧校园管理平台、一卡通卡务管理系统、一卡通人脸库管理平台、智能人脸识别消费管理系统、疫情防控管理系统、人脸识别无感识别管理系统、会议签到管理系统、人脸识别通道管理系统和图书馆对接管理系统。这些系统共同构成了智慧校园的信息化基础,通过统一数据库和操作平台,实现了数据共享和信息一致性。 智能人脸识别消费管理系统通过人脸识别终端,在无需接触的情况下快速完成消费支付过程,提升了校园服务效率。疫情防控管理系统利用热成像测温技术、视频智能分析等手段,实现了对校园人员体温监测和疫情信息实时上报,提高了校园公共卫生事件的预防和控制能力。 会议签到管理系统和人脸识别通道管理系统均基于人脸识别技术,实现了会议的快速签到和图书馆等场所的高效通行管理。与图书馆对接管理系统实现了一卡通系统与图书馆管理系统的无缝集成,提升了图书借阅的便捷性。 总体而言,该智慧校园解决方案通过集成的信息化管理系统,提升了校园管理的智能化水平,优化了校园生活体验,增强了校园安全,并提高了教学和科研的效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值