HDU 1381 Crazy Search 哈希

A - Crazy Search
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.
Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
Sample Input
3 4
daababac
Sample Output
5
Hint
Huge input,scanf is recommended.



//NC进制的hash 把不同的字母对应一个整数存在num数组里
//sum=((sum * NC) + num[str[i]]) % MAX

#include<iostream>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
const int MAX = 16000000;
int N, NC, num[130], k, len, Ans;
char str[MAX];
bool Hash[MAX];
int main()
{
    cin.sync_with_stdio(false);
    while (cin >> N >> NC >> str)
    {
        memset(num, 0, sizeof(num));
        memset(Hash, 0, sizeof(Hash));
        k = 0;
        len = strlen(str);
        for (int i = 0; i < len; i++)
        {
            if (num[str[i]] == 0)
                num[str[i]] = ++k;
            if (k == NC)
                break;
        }
        Ans = len - N + 1;
        for (int i = 0; i < len - N + 1; i++)
        {
            int sum = 0;
            for (int j = i; j < i + N; j++)
                sum = sum*NC + num[str[j]];
            sum %= MAX;
            if (!Hash[sum])
                Hash[sum] = true;
            else
                Ans--;
        }
        cout << Ans << '\n';
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值