HDU5480: Conturbatio

Description

There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place. 

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook? 

Input

The first line of the input is a integer  , meaning that there are   test cases. 

Every test cases begin with four integers 
 is the number of Rook,   is the number of queries. 

Then   lines follow, each contain two integers   describing the coordinate of Rook. 

Then   lines follow, each contain four integers   describing the left-down and right-up coordinates of query. 






Output

For every query output "Yes" or "No" as mentioned above.

Sample Input

2
2 2 1 2
1 1
1 1 1 2
2 1 2 2
2 2 2 1
1 1
1 2
2 1 2 2

Sample Output

Yes
No
Yes

给一个矩阵(给的是左上角和右下角坐标)  是否能够被车全部攻击到
只要矩阵每行都有一个车  或者  每列有一个车就可以
记录哪行哪列有车

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
int x[100001];
int y[100001];
int main()
{
	int t;
	int n,m,k,q;
	scanf("%d",&t);
	while(t--)
	{
		memset(x,0,sizeof(x));
		memset(y,0,sizeof(y));
		scanf("%d%d%d%d",&n,&m,&k,&q);
		int dx,dy;
		while(k--)
		{
			scanf("%d%d",&dx,&dy); 
			x[dx]=1;
			y[dy]=1;
		}
	   for(int i=1;i<=n;i++)
	   {
	   	x[i]+=x[i-1];//这里我有特意画了个图理解
	   }
	   for(int i=0;i<=m;i++)
	   {
	   	y[i]+=y[i-1];
	   }
	   int x1,y1,x2,y2;
	   while(q--)
	   {
	   	scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
	   	if(x[x2]-x[x1-1]==x2-x1+1||y[y2]-y[y1-1]==y2-y1+1)
	   	printf("Yes\n");
		   else
		   printf("No\n"); 
	   }
	 } 
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值