Error:Unable to load class ‘org.gradle.api.publication.maven.internal.DefaultMavenFactory’

转载请注明来源: http://blog.csdn.net/kjunchen/article/details/50850878

Error:Unable to load class ‘org.gradle.api.publication.maven.internal.DefaultMavenFactory’.


在Android studio中开发项目遇到这个问题(Error:Unable to load class ‘org.gradle.api.publication.maven.internal.DefaultMavenFactory’.),在网上找了很长时间才解决掉。

发现是版本的问题,当你使用的Gradle 版本 2.4以上,Android studio版本1.3.0以上的时候就会出现这个问题。


解决方法:

1、在相应的Module的build.gradle中修改plugin,从

apply plugin: 'android-maven' 

apply plugin: 'com.github.dcendents.android-maven' 

2、在Project级别的build.gradle中修改gradle版本,从

classpath 'com.github.dcendents:android-maven-plugin:1.2'

classpath 'com.github.dcendents:android-maven-gradle-plugin:1.3'  

参考文档:
http://stackoverflow.com/questions/32988669/how-to-solve-gradle-sync-failed-error-defaultmavenfactory

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

打赏
文章很值,打赏犒劳作者一下
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页

打赏

Junk Chen

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者