The Triangle

The Triangle

        时间限制:1000 ms  |  内存限制:65535 KB
                     难度:4

描述
这里写图片描述
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出

Your program is to write to standard output. The highest sum is written as an integer.

样例输入

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

样例输出

30

       这题,看起来好像是一道非常简单的搜索题,但是你尝试过之后就会知道他会亲切的提示你(TimeLimitExceeded),没错别问我怎么知道的,我不会告诉你我用深搜提交了四次的。这道题如果你知道他是一道很简单的DP题就好没有什么难度了,坑就坑在它太像搜索了。
代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int a[105][105];///构建两个数组一个储存原数组;
    int str[105][105];///另一个储存到相加到这里的最大值;      
    int maxx,n;
    scanf("%d",&n);
    memset(str,-1,sizeof(str));///初始化最大值数组,令他小于0,不会对模拟过程产生影响;
    for(i=0;i<n;i++)
        for(j=0;j<=i;j++)
            scanf("%d",&a[i][j]);
    str[0][0]=a[0][0];
    for(int i=0;i<n;i++)
        for(int j=0;j<=i;j++)
        {
            if(str[i+1][j]<a[i+1][j]+str[i][j])             
                str[i+1][j]=a[i+1][j]+str[i][j];
            if(str[i+1][j+1]<a[i+1][j+1]+str[i][j])
                str[i+1][j+1]=a[i+1][j+1]+str[i][j];
        }
    maxx=0;///找出最后一行中的最大值;
    for(int j=0,i=n-1;j<n;j++)
    {
        if(str[i][j]>maxx)
            maxx=str[i][j];
    }
    printf("%d\n",maxx);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值