Out of Hay---最小生成树

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

题目大意:Bessie在1农场,给出一些到其他农场的路径,从1可以到其他各个农场,求在她走过各个农场之后的最短路径,输出最短路径中最长的边,需要注意的是,从一个 农场到另一个农场的路径不只有一条,所以就要选出一条最短的。

AC代码:

#include<cstdio>
#include<iostream>
const int INF=0x3f3f3f3f;  //最大值
using namespace std;
const int max_n=2005;

int lowcost[max_n];   //当它等于0时表示已经加入到最小树中,用来记录与某个点相连的边的权值
int edge[max_n][max_n];
int ans; //记录最大边

void prim(int n)
{
	for(int i=1;i<=n;i++){
        lowcost[i]=edge[1][i];  //先将与起始点相连的边的权值记录下来
	}
	for(int i=2;i<=n;i++){
        int k=0,minn,j=1;
        minn=INF;
        while(j<=n){
        if(lowcost[j]!=0&&lowcost[j]<minn){//若该边没有加入到树中且与其相连的边的权值小于INF
            minn=lowcost[j];
            k=j;  //记录下来
        }
        j++;
        }
        if(minn>ans&&minn!=INF)
            ans=minn;  //得到最大的边
        lowcost[k]=0;
        for(int j=1;j<=n;j++){
            if(lowcost[j]!=0&&edge[k][j]<lowcost[j]){ //查找与K相连的边并记录
                lowcost[j]=edge[k][j];
            }
        }
	}
}

int main()
{
	int m,n,s,e,b;
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
        for(int j=i;j<=n;j++)
        {
            if(i==j)
                edge[i][j]=0;
            else
                edge[i][j]=edge[j][i]=INF; //初始化
        }
	for(int i=0;i<m;i++){
        scanf("%d%d%d",&s,&e,&b);
        if(edge[s][e]>b)
            edge[s][e]=edge[e][s]=b;  //建立邻接矩阵
	}
	prim(n);
	printf("%d\n",ans);
	return 0;
}

题目链接:http://poj.org/problem?id=2395

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值