L - Computer 树的直径(bfs)

A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 



Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input

5
1 1
2 1
3 1
1 1

Sample Output

3
2
3
4
4

题意:多组输入,n个电脑,n-1条边,接下来n-1行,每次输入a,b,连接i+1和a;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
const int N=20000;
int head[N],dis[N],dis1[N],vis[N];
int tot,n,pp;
struct node
{
    int u,v,w,next;
} g[N];
void add(int u,int v,int w)
{
    g[tot].v=v;
    g[tot].w=w;
    g[tot].next=head[u];
    head[u]=tot++;
}
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
    memset(dis1,0,sizeof(dis1));
    memset(g,0,sizeof(g));
}
void bfs(int u)
{
    int mi=-1;
    memset(dis,0,sizeof(dis));
    memset(vis,0,sizeof(vis));
    queue<int>q;
    pp=u;
    q.push(u);
    vis[u]=1;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        for(int i=head[x]; ~i; i=g[i].next)
        {
            int v=g[i].v;
            if(!vis[v])
            {
                vis[v]=1;
                dis[v]=dis[x]+g[i].w;
                q.push(v);

                if(mi<dis[v])
                {
                    mi=dis[v];
                    pp=v;//更新端点。
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=2; i<=n; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            add(i,a,b);
            add(a,i,b);
        }
        bfs(1);//找到距离1点最远的端点
        bfs(pp);//从距离1点最远的端点开始找最远的端点,这两点距离是树的直径
        for(int i=1; i<=n; i++)
        {
            dis1[i]=dis[i];
        }//dis1数组存所有端点到一直径端点的距离
        bfs(pp);//再次bfs得到所有点到直径另一端点的距离
        for(int i=1; i<=n; i++)
        {
            printf("%d\n",max(dis[i],dis1[i]));//找最大输出
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值