HDU5605——geometr

37 篇文章 2 订阅

Problem Description
There is a point  P  at coordinate  (x,y) .
A line goes through the point, and intersects with the postive part of  X,Y  axes at point  A,B .
Please calculate the minimum possible value of  |PA||PB| .
 

Input
the first line contains a positive integer T,means the numbers of the test cases.

the next T lines there are two positive integers X,Y,means the coordinates of P.

T=500 , 0<X,Y10000 .
 

Output
T lines,each line contains a number,means the answer to each test case.



 

Sample Input
    
    
1 2 1
 

Sample Output
    
    
4 in the sample $P(2,1)$,we make the line $y=-x+3$,which intersects the positive axis of $X,Y$ at (3,0),(0,3).$|PA|=\sqrt{2},|PB|=2\sqrt{2},|PA|*|PB|=4$,the answer is checked to be the best answer.
 


#include<stdio.h>
int main()
{
	int t,x,y;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&x,&y);
		printf("%d\n",2*x*y);
	}	
	return 0;
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值